Acceleration not clean

More
01 Sep 2010 18:57 #833 by CARLO
Acceleration not clean was created by CARLO
Hi,

One other issue, on accerating I get a pulsing or hesitation throughout the RPM range up to 4000, haven't taken it higher. New fuel pump, fuel filter, coil, K&N air cleaner and dist cap. I used some Techron thru a tank of fuel hoping it might clean the injectors but didn't help. Plugs look nice and light brown. NOTE>>>THIS CAR SAT FOR 4 YEARS when I bought it, did not run. I thought I would:

1. Remove injectors and have them tested and cleaned.

2. Replace new injector seals.

3. New SP Wires.

Any suggestions ?

Please Log in or Create an account to join the conversation.

More
01 Sep 2010 19:26 #836 by srshaw3
Replied by srshaw3 on topic Acceleration not clean
I suggest you provide specific car information as it will vary widely, 928, 928S, 928S4, etc. years, US or ROW.

Please Log in or Create an account to join the conversation.

More
01 Sep 2010 19:56 #837 by Brett928S2
Replied by Brett928S2 on topic Acceleration not clean
Hi :)

Suggestions....

New rotor arm, new plugs and maybe new leads....

All the best Brett :)

Please Log in or Create an account to join the conversation.

More
01 Sep 2010 21:41 #841 by Kiln_Red
Replied by Kiln_Red on topic Acceleration not clean
Definitely check the injectors before you bother doing anything else. Also, check your vacuum with a vacuum gauge. This could also reveal a blocked catalytic converter. Exhaust back pressure can cause hesitation. Might not be a bad idea to go ahead and get a new O2 sensor too.

Can you be a bit more descriptive about the hesitation? Also, do the symptoms change once warm?

Please Log in or Create an account to join the conversation.

More
03 Sep 2010 08:44 #848 by CARLO
Replied by CARLO on topic Acceleration not clean
Thanks for the replys.

The car is a US 1983S, I also replaced the rotor. Warm or cold as you give it more gas and the revs go up it's not a clean acceleration, tends to pulse, hard to explain. I will try all your suggestions one at a time to see if I can isolate the problem. Thanks again.

Please Log in or Create an account to join the conversation.

More
03 Sep 2010 12:25 #850 by srshaw3
Replied by srshaw3 on topic Acceleration not clean
Vacuum leaks are a big issue with 928s, as suggested here, a small crack in a intake boot may allow unmetered air to enter the intake, so I would put this near the top of the list, particularly if the car has sat for quite a while.

I had an '82 that would barely run, because the intake had loose clamps on the intake boots to the runners.

Please Log in or Create an account to join the conversation.

Moderators: Rich928mm928billvvOC

Don't have an account yet? Register Now!